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IBM (YouTube.com)  
New Face CICS ‐ The CICS Explorer

• New graphical tooling interface for CICS  
– Eclipse Based 
– Connects to CICS via the CICSPlex Web User Interface (WUI) System Task
– Utilizes the existing CICSPlex RACF Security rules
– Provides:

– A scalable/intuitive way to manage your CICS environment
– The ability to create customizable task-oriented views
– Single view of CICS tools 
– Rich set of CICS views

• CICS Releases and Availability
– CICS TS V3.1 (Free IBM SupportPac PTFs Required)
– CICS TS V3.2 (Free IBM SupportPac PTF Required)
– CICS TS V4.1 and Beyond (Free orderable component)
”

IBM has “No plans to 
make this a 

chargeable product”

http://www.youtube.com/watch?v=-NzWwUi5lLw&feature=related
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• Capabilities
– User friendly

• Easy to find what you are looking for
• You are able to dynamically/easily/quickly manipulate your screen, so that 

you are only a few clicks away from the information, you REALLY want to 
see at any given time

– Expandable, via Plug-ins
• For Shops that have CICS Tools, Explorer provides an integrated view 
• Even for Shops without CICS Tools, Explorer provides an integrated view 

of their CICS Environment 
– CICS Explorer can be used to perform many, but not ALL Administration 

Functions, when connecting to a CICS TS v4.x Region, via a CMCI (CICS 
Management Client Interface) Connection 

• IBM Direction
– IBM has made a significant commitment to Explorer

• New releases GA approximately every 90 days
• IBM has setup an Explorer Forum, for users to comment and request enhancements
– CICS Explorer forum
• From a Changing workforce perspective, IBM feels that Explorer will help shorten the 

learning curve for new IT Professionals

http://www.ibm.com/developerworks/forums/forum.jspa?forumID=1475&start=0
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• IBM CICS Explorer Download Site and Options
- http://www-01.ibm.com/software/htp/cics/explorer/download/
- You will see downloads for the following 

For Linux/Windows:
• Base CICS Explorer
• CICS CM Plug-in 

(Configuration Manager)
• CICS DA  Plug-in 

(Deployment Assistant)
• CICS  IA  Plug-in

(Interdependency Analyzer)
• CICS PA Plug-in 

(Performance Analyzer)
• IBM Session Manager Plug-in
• CICS Transaction Gateway Plug-in

•

Since Explorer is 
Eclipse based 
anyone could build 
a Plug-in for it 

After the Base and appropriate Plug-ins are installed you can connect to Any/All of the above  

http://www-01.ibm.com/software/htp/cics/explorer/download/
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• Setting up CICS Explorer Credentials
- The README file details the steps
- Credentials contain user information that will be used by Connections 
- This is an example of a Credential: 

If your Passwords change 
periodically, you may want to 
leave the “Save password” 
box unchecked.
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• Setting up CICS Explorer Connections
- You will have a Choice of three Connection Types

• System z – FTP (Required for the System z/OS Perspective)
• CICS Management Interface (CMCI) Connection, Admin CICS WUI v4.1+
• CICSPlex SM Data Interface (Read Only Connection)

- This is an example of a CMCI Connection definition:
- Name: Can be changed to  

anything you want

- Host  name: TCP/IP host name 
of your CICSPlex SM WUI server 
or your stand-alone CICS region 

- Port number: CMCI port   
configured for your WUI Server 

- Credentials dropdown: Point to 
any Credential you created
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• CICSPlex WUI Connections
- You connect via Explorer as a WUI User

• Authentication takes place just as if you were logged onto the WUI
- The Same Security rules apply

• Explorer “respects” WUI Parms such as DEFAULTWARNCNT
- CICS Explorer will not let you exceed DEFAULTWARNCT. You will 

see the following in the Lower Left-hand corner of the screen:

- CICS Explorer will not display any information (ex: Terminal Details) till 
you filter to a result set that is smaller than the WUI 
DEFAULTWARNCT
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• Starting Explorer for the first time
- The workbench starts and the Welcome View is displayed 

• Click on an icon to go to the desired Explorer target  

Overview
Get an overview of the features

Tutorials
Go through tutorials

First Steps
Take you first 
steps

Workbench
Go to the workbench

You can re-open the 
Welcome View at any 
time by Selecting 

Help > Welcome 

From the workbench 
menu bar. 

Note: A CICS 
Explorer Workspace 
is Created the first 
time you launch 
Explorer  
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• What is the CICS Explorer Workspace?
- As with a traditional Eclipse workbench, CICS Explorer stores all user 

specific information in the users CICS Explorer Workspace.
• The user specific information includes:

- Credentials - Connections - etc.
- Last display - CICS Event 

Processing Projects
• Default Location: "C:\Documents And Settings\username\.cicsexplorer”
• You can have more than one instance of Explorer running concurrently.

- Each instance must have its own workspace. 
- Example to start a new instance from a command line 

Change to the directory folder cicsexplorer.exe is installed in 
Type the following command:

cicsexplorer.exe -data "C:\Documents And Settings\username\.cicsexplorer2" 
Note: This starts the new instance using a new .cicsexplorer2 workspace
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• Intended Users
- Number of users 
- Current WUI Users 

- User Type (Administrators, Read Only, Mixed)
- Will certain groups use Plug-ins?
- User Support

• Upgrade Administration
- Frequency (New  Releases Every 90 Days)
- Upgrade method

• Full Replacement
• Automatic Update
• Archive Site File 

- Plug-in Upgrades
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• Installation Specific Audit Requirements
- Change Control
- Processes and Procedures
- Service Level Agreements

• Workspace Administration
- Backup
- Recovery
- Connection Administration
- CICS Event Processing Project Administration
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• Intended Users
- Migrate the Current WUI users (1,000+) to CICS Explorer  
- User Types Include:

• System Programmers
• Operators

- Some User Types will use appropriate Plug-ins
- Note: Not all users will have an IBMLINK ID or PC Admin Rights

• Upgrade Administration
- Due to Release Frequency, Installation Audit Requirements, and Plug-

in upgrade considerations, the Archive Site File Upgrade Method is 
chosen

Note: This example is intended to highlight issues that MIGHT arise, with a given 
deployment method. Much will depend on Installation Specific factors.   

• Application Developers
• Offshore Personnel
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• Installation Specific Audit Requirements
- Strict Change Control guidelines must be adhered to, for all 

Deployment and Upgrade activities.
- The CICS Explorer SLA availability target is 24x7/365 

• Workspace Administration Criteria
- Provide workspace Backup and Recovery
- Provide Central control for Connection Administration
- CICS Event Processing Project Administration is not currently an issue
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• Option One - Local on Each User Workstation
- Each user has an individual copy installed on their workstation  

Advantages
• Fastest connect time

Dis-Advantages
• No Central Administration

- No control of Local user versions
- Connections must be managed 
by each user 

- No control of Plug-ins
- No central method for upgrades 
or fixes 

- Problematic user support
• IBMLINK ID or Central download 

point Required    
• No Central support for CICS Explorer  
Workspace backup/restoral
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• Option Two - Shared Network Drive
- Installed/Accessed from a Shared Network Drive     

Advantages
• Partial Central Administration

- Version
- Updates
- Plug-ins

• No need for a central download point 

Dis-Advantages
• Due to installation specific Network 

Architecture, Connection time is 
approx 2 hours

• Response time, after connect 
severely degraded   

• No Central Connection Admin 
• No Central support for CICS Explorer  
Workspace backup/restoral 

• Security level available unacceptable
• Instance for offshore staff would   
require unique administration 

• Subject to Shared Drive Failure
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• Option Three - Linux
- Installed on z/Linux, utilizing z/VM      

Advantages
• Full Central Administration

- Version - Updates
- Plug-ins - Connections

• No need for a central download point
• Central support for CICS Explorer   
Workspace backup/restoral 

Dis-Advantages
• Workstation client required
• Currently not supported by IBM

- The Base CICS explorer 
package contains compiled intel 
platform Linux code. It’s not 
distributed as purely Java. It can’t 
be used for Linux on zSeries w/o 
modifying it in a method currently 
not supported by IBM
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• Option Four - Streamed Isolated Environment
- Runs in an isolated environment like a tunnel, between the user workstation 

and the Citrix servers. The app is not physically installed in the Citrix server but 
it runs and grabs the necessary files (such as registry keys, DLLs,etc) as it 
needs them. Screen updates and user keystrokes are sent back and forth via 
the isolated environment.

- Advantages
• Partial Central Administration

- Version
- Updates
- Plug-ins 

• No need for a central download point

Dis-Advantages
• No Central Connection Admin
• Connection time a minute and a half
• No Central support for CICS Explorer   
Workspace backup/restoral 

• Unstable
- Multiple errors encountered 
while testing this option
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• Option Five - Citrix Server
- Installed on a Network (Citrix) Server      

Advantages
• Full Central Administration

- Version - Updates
- Plug-ins - Connections  

• No need for a central download point
• Central support for CICS Explorer   
Workspace backup/restoral 

• Response time (after connection) 
mirrors Local Workstation option

• Highly Secure
• Server supported by the Citrix Group
• Ability to Leverage Citrix Scripting

Dis-Advantages
• Workstation client required
• Connection time 45 seconds 
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• Citrix Server Deployment Diagram

Citrix One
• SysProg (Primary)

Citrix Two
• Oper A (Primary)
• Oper B (Backup)

Citrix Three
• Dev A (Primary)
• Dev B (Backup)
• Dev C (Backup)

Citrix Four
• SysProg (Backup)

Citrix Five
• Oper A (Backup)
• Oper B (Primary)

Citrix Six
• Dev A (Backup)
• Dev B (Primary)
• Dev C (Primary)

Citrix Scripting – CICS Explorer Workspace Administration
- A “Master” workspace, containing all the Connections and starting credentials is uploaded to each Server 
- Each time a user logs on, Citrix Logon scripting checks for:

• The users workspace. If none is found, the “Master”  is copied to the users directory
• A “Newer” (Date/Time) “Master” workspace. If  the “Master” is newer than the users workspace, the 

users workspace will be replaced with a copy of the new “Master”
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• Accessing Help and What’s New
The frequency of 
New CICS Explorer 
Releases makes 
the Internal Help 
function a great 
(UTD) information 
source.

Each New Release 
includes a “What’s 
New” section, 
detailing new 
functionality  
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• Accessing the Connections Menu

Click on the 
Connection 
Menu Icon 
and Select 

Click on Window > Preferences > Connections 
and Select 



Basic Navigation (Default Perspective) 
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Explorer View - Only View  that can’t be moved Individual Resource Tabs

Explorer 
Control the 
Scope of 
Resources 
Being Viewed

Event Tab
View System 
Events

Repo View
CICSGRP(s) 
and  
CICSSYS(s) 
Def’s. Can 
also be used 
to Control 
Scope 

Perspective Selection
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• Zoom In/Out of a View
- Double Click the View Tab to Zoom in or Back out of a view



Basic Navigation (Manipulating a View) 
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• Resizing a View 
- Float the Cursor over the inside edge of the view until it changes to a 

Double-Ended arrow. 
- Drag the edge to the desired size

• Moving a View
– Position the Cursor on the 

Tab of the View you want 
to move

– Drag it to the area of the 
screen you want to 
position it in.

• Your cursor will change to 
one of the following, 
indicating where the 
screen will be positioned.

Cursor Where the View will be moved

Position above the Current View (the View that 
is underneath the cursor) 

Position Below the Current View 

Position to the Right of the Current View

Position to the Left of the Current View

Stack: The View is stacked as a Tab in the 
Current View

Restricted: Can’t be positioned in Current Area

Open a New Window. Drag outside the 
workbench to position in a new window. Note: 
Click on the New Window and Drag Back to 
position it back 
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• Move Column - Click on Column and Drag to the Desired Location
• From the View Menu you can: 

• Customize 
Columns

• Refresh the View
• Reset Columns
• Equalize Column   

Widths

• Choose filter   
attributes



Basic Navigation (Operations Tasks) 

Page 26

Filter of EYU* UsedRight click on an individual entry to take Action on it. Refresh View

Actions Available 

Perform actions on Multiple Entries, that are grouped together by 
doing Click, Shift, Click (to Select), and then Right Click

Perform actions on Entries not grouped together by doing Click, 
CTRL, Click, CTRL (to Select ), and then Right Click 
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